using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)=(['\""]|")(.*?)\2";
string input = @"Parameter1=""Something related to this"" Parameter2=""Another value"" Parameter3='Single quotes are permitted' Parameter4="Even HTML entities are permitted"";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}