re = /(\w+)=(['\"]|")(.*?)\2/m
str = 'Parameter1="Something related to this" Parameter2="Another value" Parameter3=\'Single quotes are permitted\' Parameter4="Even HTML entities are permitted"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end