$re = '/(\w+)=([\'\"]|")(.*?)\2/m';
$str = 'Parameter1="Something related to this" Parameter2="Another value" Parameter3=\'Single quotes are permitted\' Parameter4="Even HTML entities are permitted"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);