#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(MB_PKW|MB_VAN|MB_LKW|Omnibus)\/xports\/QL\/QL_AS_(.+?)\.xml"
Local $sString = "/Omnibus/xports/EDAS/EvoBus_ABS02T.edas.xml " & @CRLF & _
"/MB_VAN/xports/EDAS/VAN_AIRBAG470.edas.xml " & @CRLF & _
"/MB_LKW/xports/edas/LKW_VRDU01T.edas.xml " & @CRLF & _
"/MB_PKW/xports/EDAS/PKW_ADAS_GW453.edas.xml " & @CRLF & _
"/MB_VAN/xports/QL/QL_AS_CONNECT907.xml " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")