$re = '/(MB_PKW|MB_VAN|MB_LKW|Omnibus)\/xports\/QL\/QL_AS_(.+?)\.xml/mi';
$str = '/Omnibus/xports/EDAS/EvoBus_ABS02T.edas.xml
/MB_VAN/xports/EDAS/VAN_AIRBAG470.edas.xml
/MB_LKW/xports/edas/LKW_VRDU01T.edas.xml
/MB_PKW/xports/EDAS/PKW_ADAS_GW453.edas.xml
/MB_VAN/xports/QL/QL_AS_CONNECT907.xml
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);