use strict;
my $str = '/Omnibus/xports/EDAS/EvoBus_ABS02T.edas.xml
/MB_VAN/xports/EDAS/VAN_AIRBAG470.edas.xml
/MB_LKW/xports/edas/LKW_VRDU01T.edas.xml
/MB_PKW/xports/EDAS/PKW_ADAS_GW453.edas.xml
/MB_VAN/xports/QL/QL_AS_CONNECT907.xml
';
my $regex = qr/(MB_PKW|MB_VAN|MB_LKW|Omnibus)\/xports\/QL\/QL_AS_(.+?)\.xml/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}