import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
    public static void main(String[] args) {
        final String regex = "\\[(plantuml.+)\\]\\s+\\.{4}\\s([\\s\\S]+?(?=^\\.{4}))\\.{4}";
        final String string = "= Title\n\n"
	 + "[plantuml, target=diagram-classes, format=png]\n"
	 + "....\n"
	 + "class BlockProcessor\n"
	 + "class DiagramBlock\n"
	 + "class DitaaBlock\n"
	 + "class PlantUmlBlock\n\n"
	 + "BlockProcessor <|-- DiagramBlock\n"
	 + "DiagramBlock <|-- DitaaBlock\n"
	 + "DiagramBlock <|-- PlantUmlBlock\n"
	 + "....\n\n"
	 + "[plantuml, target=blabla, fasdf=asfdas]\n"
	 + "....\n"
	 + "class BlockProcessor\n"
	 + "class DiagramBlock\n"
	 + "class DitaaBlock\n"
	 + "class PlantUmlBlock\n\n"
	 + "BlockProcessor <|... DiagramBlock\n"
	 + "DiagramBlock <|...... DitaaBlock\n"
	 + "DiagramBlock <|..... PlantUmlBlock\n"
	 + "....\n\n"
	 + "[source, java]\n"
	 + "....\n"
	 + "class BlockProcessor\n"
	 + "class DiagramBlock\n"
	 + "class DitaaBlock\n"
	 + "class PlantUmlBlock\n\n"
	 + "BlockProcessor <|-- DiagramBlock\n"
	 + "DiagramBlock <|-- DitaaBlock\n"
	 + "DiagramBlock <|-- PlantUmlBlock\n"
	 + "....\n\n\n";
        
        final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
        final Matcher matcher = pattern.matcher(string);
        
        while (matcher.find()) {
            System.out.println("Full match: " + matcher.group(0));
            
            for (int i = 1; i <= matcher.groupCount(); i++) {
                System.out.println("Group " + i + ": " + matcher.group(i));
            }
        }
    }
}