import re
regex = re.compile(r"\[(plantuml.+)\]\s+\.{4}\s([\s\S]+?(?=^\.{4}))\.{4}", flags=re.MULTILINE)
test_str = ("= Title\n\n"
"[plantuml, target=diagram-classes, format=png]\n"
"....\n"
"class BlockProcessor\n"
"class DiagramBlock\n"
"class DitaaBlock\n"
"class PlantUmlBlock\n\n"
"BlockProcessor <|-- DiagramBlock\n"
"DiagramBlock <|-- DitaaBlock\n"
"DiagramBlock <|-- PlantUmlBlock\n"
"....\n\n"
"[plantuml, target=blabla, fasdf=asfdas]\n"
"....\n"
"class BlockProcessor\n"
"class DiagramBlock\n"
"class DitaaBlock\n"
"class PlantUmlBlock\n\n"
"BlockProcessor <|... DiagramBlock\n"
"DiagramBlock <|...... DitaaBlock\n"
"DiagramBlock <|..... PlantUmlBlock\n"
"....\n\n"
"[source, java]\n"
"....\n"
"class BlockProcessor\n"
"class DiagramBlock\n"
"class DitaaBlock\n"
"class PlantUmlBlock\n\n"
"BlockProcessor <|-- DiagramBlock\n"
"DiagramBlock <|-- DitaaBlock\n"
"DiagramBlock <|-- PlantUmlBlock\n"
"....\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")