#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi){\s*file\s*:\s*["']\s*(http[^"']+\.mp4)"
Local $sString = "<!DOCTYPE html>" & @CRLF & _
"<html>" & @CRLF & _
"<head>" & @CRLF & _
"<meta charset="UTF-8" />" & @CRLF & _
"<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1" />" & @CRLF & _
"<link href='https://fonts.googleapis.com/css?family=Hanuman' rel='stylesheet' type='text/css'>" & @CRLF & _
"<link href="https://fonts.googleapis.com/css?family=Scada" rel="stylesheet">" & @CRLF & _
"<link href="jwplayer-7.12.8/skins/prime.min2.css" rel="stylesheet" type="text/css" />" & @CRLF & _
"<script type="text/javascript" src="jwplayer-7.12.8/jwplayer.js"></script>" & @CRLF & _
"<script type="text/javascript">jwplayer.key="I9HOJrL1NmqruQ60as34wt34/23422dsdrwer==";</script>" & @CRLF & _
"</head>" & @CRLF & _
"<body>" & @CRLF & _
"<div id="picasa" class="picasa"></div>" & @CRLF & _
"<script type="text/javascript">" & @CRLF & _
" var playerInstance = jwplayer("picasa");" & @CRLF & _
" playerInstance.setup({" & @CRLF & _
" id:'picasa'," & @CRLF & _
" controls: true," & @CRLF & _
" displaytitle: true," & @CRLF & _
"" & @CRLF & _
" flashplayer: "//ssl.p.jwpcdn.com/player/v/7.12.5/jwplayer.flash.swf"," & @CRLF & _
" width: "100%"," & @CRLF & _
" height: "100%"," & @CRLF & _
" aspectratio: "16:9"," & @CRLF & _
" fullscreen: "true"," & @CRLF & _
" provider: 'http'," & @CRLF & _
" autostart: false," & @CRLF & _
" image:'http://localhost/viral/viralvideo.jpg'," & @CRLF & _
" sources: [{file:"http://localhost/srt/43534234/viral022018SD.MP4",label:"SD",type: "video/mp4"},{file:"http://localhost/srt/43534234/viral022018HD.MP4",label:"HD",type: "video/mp4",default: true}]," & @CRLF & _
" sharing:{" & @CRLF & _
" link: ""," & @CRLF & _
" code: ""," & @CRLF & _
" heading: "Share"," & @CRLF & _
" sites: ["facebook","twitter","tumblr","googleplus","reddit","linkedin","interest","email"]," & @CRLF & _
" }," & @CRLF & _
"sharing:{" & @CRLF & _
" link: ""," & @CRLF & _
" code: ""," & @CRLF & _
" heading: "Share"," & @CRLF & _
" sites: ["facebook","twitter","tumblr","googleplus","reddit","linkedin","interest","email"]," & @CRLF & _
" }," & @CRLF & _
"tracks: [{" & @CRLF & _
" file: 'http://localhost/srt/viralvideo022018.srt'," & @CRLF & _
" label: 'English'," & @CRLF & _
" kind: 'captions'," & @CRLF & _
" "default":true" & @CRLF & _
"}]," & @CRLF & _
"" & @CRLF & _
" captions: {" & @CRLF & _
" color: '#FFEB3B'," & @CRLF & _
" fontSize: 14," & @CRLF & _
" fontFamily: 'Scada, Hanuman, sans-serif, Verdana, cursive'," & @CRLF & _
" fontOpacity: 100," & @CRLF & _
" backgroundOpacity: 0," & @CRLF & _
"backgroundColor: '#000000'," & @CRLF & _
" edgeStyle: 'raised'," & @CRLF & _
" windowColor: '#000000'," & @CRLF & _
" windowOpacity: 0" & @CRLF & _
" }," & @CRLF & _
"skin: {" & @CRLF & _
" name: 'prime'," & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" });" & @CRLF & _
"" & @CRLF & _
"</script>" & @CRLF & _
"</body>" & @CRLF & _
"</html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")