import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\s*file\\s*:\\s*[\"']\\s*(http[^\"']+\\.mp4)";
final String string = "<!DOCTYPE html>\n"
+ "<html>\n"
+ "<head>\n"
+ "<meta charset=\"UTF-8\" />\n"
+ "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1, maximum-scale=1\" />\n"
+ "<link href='https://fonts.googleapis.com/css?family=Hanuman' rel='stylesheet' type='text/css'>\n"
+ "<link href=\"https://fonts.googleapis.com/css?family=Scada\" rel=\"stylesheet\">\n"
+ "<link href=\"jwplayer-7.12.8/skins/prime.min2.css\" rel=\"stylesheet\" type=\"text/css\" />\n"
+ "<script type=\"text/javascript\" src=\"jwplayer-7.12.8/jwplayer.js\"></script>\n"
+ "<script type=\"text/javascript\">jwplayer.key=\"I9HOJrL1NmqruQ60as34wt34/23422dsdrwer==\";</script>\n"
+ "</head>\n"
+ "<body>\n"
+ "<div id=\"picasa\" class=\"picasa\"></div>\n"
+ "<script type=\"text/javascript\">\n"
+ " var playerInstance = jwplayer(\"picasa\");\n"
+ " playerInstance.setup({\n"
+ " id:'picasa',\n"
+ " controls: true,\n"
+ " displaytitle: true,\n\n"
+ " flashplayer: \"//ssl.p.jwpcdn.com/player/v/7.12.5/jwplayer.flash.swf\",\n"
+ " width: \"100%\",\n"
+ " height: \"100%\",\n"
+ " aspectratio: \"16:9\",\n"
+ " fullscreen: \"true\",\n"
+ " provider: 'http',\n"
+ " autostart: false,\n"
+ " image:'http://localhost/viral/viralvideo.jpg',\n"
+ " sources: [{file:\"http://localhost/srt/43534234/viral022018SD.MP4\",label:\"SD\",type: \"video/mp4\"},{file:\"http://localhost/srt/43534234/viral022018HD.MP4\",label:\"HD\",type: \"video/mp4\",default: true}],\n"
+ " sharing:{\n"
+ " link: \"\",\n"
+ " code: \"\",\n"
+ " heading: \"Share\",\n"
+ " sites: [\"facebook\",\"twitter\",\"tumblr\",\"googleplus\",\"reddit\",\"linkedin\",\"interest\",\"email\"],\n"
+ " },\n"
+ "sharing:{\n"
+ " link: \"\",\n"
+ " code: \"\",\n"
+ " heading: \"Share\",\n"
+ " sites: [\"facebook\",\"twitter\",\"tumblr\",\"googleplus\",\"reddit\",\"linkedin\",\"interest\",\"email\"],\n"
+ " },\n"
+ "tracks: [{\n"
+ " file: 'http://localhost/srt/viralvideo022018.srt',\n"
+ " label: 'English',\n"
+ " kind: 'captions',\n"
+ " \"default\":true\n"
+ "}],\n\n"
+ " captions: {\n"
+ " color: '#FFEB3B',\n"
+ " fontSize: 14,\n"
+ " fontFamily: 'Scada, Hanuman, sans-serif, Verdana, cursive',\n"
+ " fontOpacity: 100,\n"
+ " backgroundOpacity: 0,\n"
+ "backgroundColor: '#000000',\n"
+ " edgeStyle: 'raised',\n"
+ " windowColor: '#000000',\n"
+ " windowOpacity: 0\n"
+ " },\n"
+ "skin: {\n"
+ " name: 'prime',\n"
+ " },\n\n\n\n\n"
+ " });\n\n"
+ "</script>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}