# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{\s*file\s*:\s*[\"']\s*(http[^\"']+\.mp4)"
test_str = ("<!DOCTYPE html>\n"
"<html>\n"
"<head>\n"
"<meta charset=\"UTF-8\" />\n"
"<meta name=\"viewport\" content=\"width=device-width, initial-scale=1, maximum-scale=1\" />\n"
"<link href='https://fonts.googleapis.com/css?family=Hanuman' rel='stylesheet' type='text/css'>\n"
"<link href=\"https://fonts.googleapis.com/css?family=Scada\" rel=\"stylesheet\">\n"
"<link href=\"jwplayer-7.12.8/skins/prime.min2.css\" rel=\"stylesheet\" type=\"text/css\" />\n"
"<script type=\"text/javascript\" src=\"jwplayer-7.12.8/jwplayer.js\"></script>\n"
"<script type=\"text/javascript\">jwplayer.key=\"I9HOJrL1NmqruQ60as34wt34/23422dsdrwer==\";</script>\n"
"</head>\n"
"<body>\n"
"<div id=\"picasa\" class=\"picasa\"></div>\n"
"<script type=\"text/javascript\">\n"
" var playerInstance = jwplayer(\"picasa\");\n"
" playerInstance.setup({\n"
" id:'picasa',\n"
" controls: true,\n"
" displaytitle: true,\n\n"
" flashplayer: \"//ssl.p.jwpcdn.com/player/v/7.12.5/jwplayer.flash.swf\",\n"
" width: \"100%\",\n"
" height: \"100%\",\n"
" aspectratio: \"16:9\",\n"
" fullscreen: \"true\",\n"
" provider: 'http',\n"
" autostart: false,\n"
" image:'http://localhost/viral/viralvideo.jpg',\n"
" sources: [{file:\"http://localhost/srt/43534234/viral022018SD.MP4\",label:\"SD\",type: \"video/mp4\"},{file:\"http://localhost/srt/43534234/viral022018HD.MP4\",label:\"HD\",type: \"video/mp4\",default: true}],\n"
" sharing:{\n"
" link: \"\",\n"
" code: \"\",\n"
" heading: \"Share\",\n"
" sites: [\"facebook\",\"twitter\",\"tumblr\",\"googleplus\",\"reddit\",\"linkedin\",\"interest\",\"email\"],\n"
" },\n"
"sharing:{\n"
" link: \"\",\n"
" code: \"\",\n"
" heading: \"Share\",\n"
" sites: [\"facebook\",\"twitter\",\"tumblr\",\"googleplus\",\"reddit\",\"linkedin\",\"interest\",\"email\"],\n"
" },\n"
"tracks: [{\n"
" file: 'http://localhost/srt/viralvideo022018.srt',\n"
" label: 'English',\n"
" kind: 'captions',\n"
" \"default\":true\n"
"}],\n\n"
" captions: {\n"
" color: '#FFEB3B',\n"
" fontSize: 14,\n"
" fontFamily: 'Scada, Hanuman, sans-serif, Verdana, cursive',\n"
" fontOpacity: 100,\n"
" backgroundOpacity: 0,\n"
"backgroundColor: '#000000',\n"
" edgeStyle: 'raised',\n"
" windowColor: '#000000',\n"
" windowOpacity: 0\n"
" },\n"
"skin: {\n"
" name: 'prime',\n"
" },\n\n\n\n\n"
" });\n\n"
"</script>\n"
"</body>\n"
"</html>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.