$re = '/change://(?:problem/)?(\d+)/m';
$str = '<change://problem/59689726> This is a test1
change://1234567 This is a test2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);