import re
regex = re.compile(r"change://(?:problem/)?(\d+)", flags=re.MULTILINE)
test_str = ("<change://problem/59689726> This is a test1\n"
"change://1234567 This is a test2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")