package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)INEMP\d{3,4}`)
var str = `Ref: HR/Personal File/INEMP913/4-6 November 3, 2011`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}