$re = '/INEMP\d{3,4}/m';
$str = 'Ref: HR/Personal File/INEMP913/4-6 November 3, 2011';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);