const regex = /INEMP\d{3,4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('INEMP\\d{3,4}', 'gm')
const str = `Ref: HR/Personal File/INEMP913/4-6 November 3, 2011`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}