import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\{[\\dA-F]{8}(?:-([\\dA-F]{4}-){3}|[\\dA-F]{12})[0-9A-F]{12}\\}|\\([\\dA-F]{8}(?:-([\\dA-F]{4}-){3}|[\\dA-F]{12})[0-9A-F]{12}\\)|[\\dA-F]{8}(?:-([\\dA-F]{4}-){3}|[\\dA-F]{12})[0-9A-F]{12})$";
final String string = "CA761232 ED42 11CE BACD 00AA0057B223\n\n"
+ "CA761232-ED42-11CE-BACD-00AA0057B223";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}