re = /^(?:{[\dA-F]{8}(?:-([\dA-F]{4}-){3}|[\dA-F]{12})[0-9A-F]{12}}|\([\dA-F]{8}(?:-([\dA-F]{4}-){3}|[\dA-F]{12})[0-9A-F]{12}\)|[\dA-F]{8}(?:-([\dA-F]{4}-){3}|[\dA-F]{12})[0-9A-F]{12})$/i
str = 'CA761232 ED42 11CE BACD 00AA0057B223
CA761232-ED42-11CE-BACD-00AA0057B223'
# Print the match result
str.match(re) do |match|
puts match.to_s
end