const regex = /^(?:{[\dA-F]{8}(?:-([\dA-F]{4}-){3}|[\dA-F]{12})[0-9A-F]{12}}|\([\dA-F]{8}(?:-([\dA-F]{4}-){3}|[\dA-F]{12})[0-9A-F]{12}\)|[\dA-F]{8}(?:-([\dA-F]{4}-){3}|[\dA-F]{12})[0-9A-F]{12})$/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:{[\\dA-F]{8}(?:-([\\dA-F]{4}-){3}|[\\dA-F]{12})[0-9A-F]{12}}|\\([\\dA-F]{8}(?:-([\\dA-F]{4}-){3}|[\\dA-F]{12})[0-9A-F]{12}\\)|[\\dA-F]{8}(?:-([\\dA-F]{4}-){3}|[\\dA-F]{12})[0-9A-F]{12})$', 'i')
const str = `CA761232 ED42 11CE BACD 00AA0057B223
CA761232-ED42-11CE-BACD-00AA0057B223`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}