package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"(.*?)"`)
var str = `The fourth field should be captured as:
"|DaNita", "Da|Nita", "DaNita|" or "|DaNita|" respectively.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}