$re = '/"(.*?)"/m';
$str = 'The fourth field should be captured as:
"|DaNita", "Da|Nita", "DaNita|" or "|DaNita|" respectively.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);