re = /"(.*?)"/m
str = 'The fourth field should be captured as:
"|DaNita", "Da|Nita", "DaNita|" or "|DaNita|" respectively.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end