package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(')((?:[^\\']*)(?:\\'[^\\']*)*)(')`)
var str = `{'hi': 'coxxxxol'}{'lol': 'what\'e"ver'}
''''''''''''''''''''''''
''''''''''''''''''''''''''
title='Wow 'this' is great'`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}