import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!last calendar) day (of the month )?(next )?(preceding|prior to) (any|an|each) (interest|Bond) payment";
final String string = "following day of the month next preceding an interest payment date\n"
+ "these day of the month next preceding an Interest Payment Date (each a \"Record Date\")\n"
+ "last day of the month preceding any Bond Payment\n"
+ "record date shall be defined as the fifteenth (15 th ) day preceding any interest payment date.\n\n"
+ "The Record Date is the last calendar day of the month preceding each Interest Payment Date, whether or not such day is a Business Day.\n\n\n"
+ "calendar month immediately preceding an interest payment\n"
+ "calendar month next preceding each Interest Payment Date.\n\n\n\n"
+ "(whether or not a business day) of the calendar month before the interest payment\n\n\n"
+ "interest payable on the Bonds on any interest payment date means the close of business on the 15th day of the preceding month.\n\n\n"
+ "month prior to an Interest Payment\n"
+ "day preceding any interest payment\n"
+ "immediately preceding an interest payment date";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}