import Foundation
let pattern = #"(?<!last calendar) day (of the month )?(next )?(preceding|prior to) (any|an|each) (interest|Bond) payment"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
following day of the month next preceding an interest payment date
these day of the month next preceding an Interest Payment Date (each a "Record Date")
last day of the month preceding any Bond Payment
record date shall be defined as the fifteenth (15 th ) day preceding any interest payment date.
The Record Date is the last calendar day of the month preceding each Interest Payment Date, whether or not such day is a Business Day.
calendar month immediately preceding an interest payment
calendar month next preceding each Interest Payment Date.
(whether or not a business day) of the calendar month before the interest payment
interest payable on the Bonds on any interest payment date means the close of business on the 15th day of the preceding month.
month prior to an Interest Payment
day preceding any interest payment
immediately preceding an interest payment date
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)