re = /(?<!last calendar) day (of the month )?(next )?(preceding|prior to) (any|an|each) (interest|Bond) payment/mi
str = 'following day of the month next preceding an interest payment date
these day of the month next preceding an Interest Payment Date (each a "Record Date")
last day of the month preceding any Bond Payment
record date shall be defined as the fifteenth (15 th ) day preceding any interest payment date.
The Record Date is the last calendar day of the month preceding each Interest Payment Date, whether or not such day is a Business Day.
calendar month immediately preceding an interest payment
calendar month next preceding each Interest Payment Date.
(whether or not a business day) of the calendar month before the interest payment
interest payable on the Bonds on any interest payment date means the close of business on the 15th day of the preceding month.
month prior to an Interest Payment
day preceding any interest payment
immediately preceding an interest payment date'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end