#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)PROC DATE:\s*(?P<date>\w+)(?:(?!RID:\s+RSS-\d).)*T PUR\s+(?P<num>\d[.,\d]*)\s+(?P<val>\d[\d,]*)"
Local $sString = "RID: RSS-130 SERVICE PAGE: 2 " & @CRLF & _
"REPORTING FOR: 100019912 SSSE INTSERVICE PROC DATE: 15SEP21 " & @CRLF & _
"ROLLUP FOR: 100076212 SSSE REPORT REPORT DATE: 15SEP21 " & @CRLF & _
"ENTITY: 1000208212 SSSE " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" ACQT " & @CRLF & _
" " & @CRLF & _
" " & @CRLF & _
" PUR " & @CRLF & _
" SAME 10SEP21 120 12,263,518 19,48.5 " & @CRLF & _
" " & @CRLF & _
" T PUR 120 12,263,518 19,48.5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")