# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)PROC DATE:\s*(?P<date>\w+)(?:(?!RID:\s+RSS-\d).)*T PUR\s+(?P<num>\d[.,\d]*)\s+(?P<val>\d[\d,]*)"
test_str = ("RID: RSS-130 SERVICE PAGE: 2 \n"
"REPORTING FOR: 100019912 SSSE INTSERVICE PROC DATE: 15SEP21 \n"
"ROLLUP FOR: 100076212 SSSE REPORT REPORT DATE: 15SEP21 \n"
"ENTITY: 1000208212 SSSE \n"
" \n"
" \n"
" \n"
" \n"
" ACQT \n"
" \n"
" \n"
" PUR \n"
" SAME 10SEP21 120 12,263,518 19,48.5 \n"
" \n"
" T PUR 120 12,263,518 19,48.5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.