import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)PROC DATE:\\s*(?P<date>\\w+)(?:(?!RID:\\s+RSS-\\d|ACQT).)*ACQT(?:(?!RID:\\s+RSS-\\d).)*T PUR\\s+(?P<num>\\d[.,\\d]*)\\s+(?P<val>\\d[\\d,]*)";
final String string = "RID: RSS-130 SERVICE PAGE: 2 \n"
+ "REPORTING FOR: 100019912 SSSE INTSERVICE PROC DATE: 15SEP21 \n"
+ "ROLLUP FOR: 100076212 SSSE REPORT REPORT DATE: 15SEP21 \n"
+ "ENTITY: 1000208212 SSSE \n"
+ " \n"
+ " \n"
+ " T PUR 70 1,346,001 1,348.5 \n"
+ " \n"
+ " ACQT \n"
+ " \n"
+ " \n"
+ " PUR \n"
+ " SAME 10SEP21 120 12,263,518 19,48.5 \n"
+ " \n"
+ " T PUR 120 12,263,518 19,48.5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}