import re
regex = re.compile(r"(?s)PROC DATE:\s*(?P<date>\w+)(?:(?!RID:\s+RSS-\d|ACQT).)*ACQT(?:(?!RID:\s+RSS-\d).)*T PUR\s+(?P<num>\d[.,\d]*)\s+(?P<val>\d[\d,]*)", flags=re.MULTILINE)
test_str = ("RID: RSS-130 SERVICE PAGE: 2 \n"
"REPORTING FOR: 100019912 SSSE INTSERVICE PROC DATE: 15SEP21 \n"
"ROLLUP FOR: 100076212 SSSE REPORT REPORT DATE: 15SEP21 \n"
"ENTITY: 1000208212 SSSE \n"
" \n"
" \n"
" T PUR 70 1,346,001 1,348.5 \n"
" \n"
" ACQT \n"
" \n"
" \n"
" PUR \n"
" SAME 10SEP21 120 12,263,518 19,48.5 \n"
" \n"
" T PUR 120 12,263,518 19,48.5")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")