const regex = new RegExp('(?s)PROC DATE:\\s*(?P<date>\\w+)(?:(?!RID:\\s+RSS-\\d|ACQT).)*ACQT(?:(?!RID:\\s+RSS-\\d).)*T PUR\\s+(?P<num>\\d[.,\\d]*)\\s+(?P<val>\\d[\\d,]*)', 'gm')
const str = `RID: RSS-130 SERVICE PAGE: 2
REPORTING FOR: 100019912 SSSE INTSERVICE PROC DATE: 15SEP21
ROLLUP FOR: 100076212 SSSE REPORT REPORT DATE: 15SEP21
ENTITY: 1000208212 SSSE
T PUR 70 1,346,001 1,348.5
ACQT
PUR
SAME 10SEP21 120 12,263,518 19,48.5
T PUR 120 12,263,518 19,48.5`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}