import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[\\d-]*(?=(\\.\\d{0,2})?)(\\.\\d{0,2})?$";
final String string = "1\n"
+ "1.\n"
+ "aa.1\n"
+ "1-1222-.\n"
+ "1-1222-123.1\n"
+ "1-1222-123.11\n"
+ "1-.ы1\n"
+ "1-1222-.112\n"
+ ".12\n"
+ "1.123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}