use strict;
my $str = '1
1.
aa.1
1-1222-.
1-1222-123.1
1-1222-123.11
1-.ы1
1-1222-.112
.12
1.123';
my $regex = qr/^[\d-]*(?=(\.\d{0,2})?)(\.\d{0,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}