re = /^[\d-]*(?=(\.\d{0,2})?)(\.\d{0,2})?$/m
str = '1
1.
aa.1
1-1222-.
1-1222-123.1
1-1222-123.11
1-.ы1
1-1222-.112
.12
1.123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end