#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^127.0.0.1|168\.192\.([0-9]|[1-9][0-9]|1[0-1][0-9])\.([1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$"
Local $sString = "168.192.2.100" & @CRLF & _
"168.192.109.1" & @CRLF & _
"168.192.0.1" & @CRLF & _
"168.192.0.25" & @CRLF & _
"168.192.255.2" & @CRLF & _
"168.192.110.1" & @CRLF & _
"168.192.100.1" & @CRLF & _
"168.192.210.1" & @CRLF & _
"168.192.256.4" & @CRLF & _
"168.192.0.255" & @CRLF & _
"168.192.200.255" & @CRLF & _
"168.192.19." & @CRLF & _
"168.192.34.10" & @CRLF & _
"168.192.100.10" & @CRLF & _
"168.192.51.200" & @CRLF & _
"168.192.81.9" & @CRLF & _
"168.192.111.133" & @CRLF & _
"168.192.112.133" & @CRLF & _
"168.192.111.256" & @CRLF & _
"168.192.111.216" & @CRLF & _
"168.192.111.236" & @CRLF & _
"168.192.110.1" & @CRLF & _
"168.192.111.100" & @CRLF & _
"168.192.110.200" & @CRLF & _
"168.192.110.300" & @CRLF & _
"" & @CRLF & _
"168.192.110.1" & @CRLF & _
"168.192.110.1" & @CRLF & _
"168.192.1.9" & @CRLF & _
"168.192.100.0" & @CRLF & _
"" & @CRLF & _
"268." & @CRLF & _
"2." & @CRLF & _
"168.1." & @CRLF & _
"1.^168\.192\.([1-9]|[1-9][0-9]|[1-2][0-4][0-9]|25[0-5])\.([1-9]|[1-9][0-9]|[1-2][0-4][0-9]|25[0-5])$"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")