package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^127.0.0.1|168\.192\.([0-9]|[1-9][0-9]|1[0-1][0-9])\.([1-9]|[1-9][0-9]|1[0-9]{2}|2[0-4][0-9]|25[0-5])$`)
var str = `168.192.2.100
168.192.109.1
168.192.0.1
168.192.0.25
168.192.255.2
168.192.110.1
168.192.100.1
168.192.210.1
168.192.256.4
168.192.0.255
168.192.200.255
168.192.19.
168.192.34.10
168.192.100.10
168.192.51.200
168.192.81.9
168.192.111.133
168.192.112.133
168.192.111.256
168.192.111.216
168.192.111.236
168.192.110.1
168.192.111.100
168.192.110.200
168.192.110.300
168.192.110.1
168.192.110.1
168.192.1.9
168.192.100.0
268.
2.
168.1.
1.^168\.192\.([1-9]|[1-9][0-9]|[1-2][0-4][0-9]|25[0-5])\.([1-9]|[1-9][0-9]|[1-2][0-4][0-9]|25[0-5])$`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}