#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^gamepad\b([#\/?]?)"
Local $sString = "gamepad" & @CRLF & _
"gamepads-module-1" & @CRLF & _
"webxr-gamepad-1" & @CRLF & _
"webxr-gamepads-1" & @CRLF & _
"gamepad#foo" & @CRLF & _
"gamepad/foo#bar"
Local $sSubst = "_SPEC_$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)