// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^gamepad\b([#\/?]?)").unwrap();
let string = "gamepad
gamepads-module-1
webxr-gamepad-1
webxr-gamepads-1
gamepad#foo
gamepad/foo#bar";
let substitution = "_SPEC_$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}