import Foundation
let pattern = ##"^gamepad\b([#\/?]?)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
gamepad
gamepads-module-1
webxr-gamepad-1
webxr-gamepads-1
gamepad#foo
gamepad/foo#bar
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_SPEC_$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)