const regex = new RegExp('(?m)^(?P<datetime>\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}:\\d{2})(?:\\:\\s)(?P<log>(.*\\s\\s.*|.*)+)', 'gm')
const str = `2022-03-01T12:04:52: Here is a log message
that spans multiple lines
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: Here is another message
that spans multiple lines
and another
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: Here is another message
that spans multiple lines
2022-03-01T12:04:52: This is a single line`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}