re = /(?m)^(?P<datetime>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2})(?:\:\s)(?P<log>(.*\s\s.*|.*)+)/m
str = '2022-03-01T12:04:52: Here is a log message
that spans multiple lines
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: Here is another message
that spans multiple lines
and another
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: Here is another message
that spans multiple lines
2022-03-01T12:04:52: This is a single line'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end