// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?m)^(?P<datetime>\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2})(?:\:\s)(?P<log>(.*\s\s.*|.*)+)").unwrap();
let string = "2022-03-01T12:04:52: Here is a log message
that spans multiple lines
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: Here is another message
that spans multiple lines
and another
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: This is a single line
2022-03-01T12:04:52: Here is another message
that spans multiple lines
2022-03-01T12:04:52: This is a single line";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}