using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""(\w+)"":""?([^"",}]+)""?";
string input = @"2024-07-08T04:43:32.468537+00:00 dxx1-dbxxxs.xxx.net MSSQLSERVER[0] {""EventTime"":""2024-07-08 04:43:32"",""Hostname"":""dx1-dbxxxs.xxx.net"",""Keywords"":45035996273704960,""EventType"":""AUDIT_SUCCESS"",""SeverityValue"":2,""Severity"":""INFO"",""EventID"":44444,""SourceName"":""MSSQLSERVER"",""Task"":5,""RecordNumber"":1234343410,""ProcessID"":0,""ThreadID"":0,""Channel"":""Application"",""Message"":""Audit event:lkjfd:sdfkjhf:Askjhdfsdf"",""Category"":""None"",""EventReceivedTime"":""2024-07-08 04:43:32"",""SourceModuleName"":""default-inputs"",""SourceModuleType"":""im_msvistalog""}#015";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}