// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"(\w+)":"?([^",}]+)"?"#).unwrap();
let string = "2024-07-08T04:43:32.468537+00:00 dxx1-dbxxxs.xxx.net MSSQLSERVER[0] {\"EventTime\":\"2024-07-08 04:43:32\",\"Hostname\":\"dx1-dbxxxs.xxx.net\",\"Keywords\":45035996273704960,\"EventType\":\"AUDIT_SUCCESS\",\"SeverityValue\":2,\"Severity\":\"INFO\",\"EventID\":44444,\"SourceName\":\"MSSQLSERVER\",\"Task\":5,\"RecordNumber\":1234343410,\"ProcessID\":0,\"ThreadID\":0,\"Channel\":\"Application\",\"Message\":\"Audit event:lkjfd:sdfkjhf:Askjhdfsdf\",\"Category\":\"None\",\"EventReceivedTime\":\"2024-07-08 04:43:32\",\"SourceModuleName\":\"default-inputs\",\"SourceModuleType\":\"im_msvistalog\"}#015";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}