# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"(\w+)\":\"?([^\",}]+)\"?"
test_str = "2024-07-08T04:43:32.468537+00:00 dxx1-dbxxxs.xxx.net MSSQLSERVER[0] {\"EventTime\":\"2024-07-08 04:43:32\",\"Hostname\":\"dx1-dbxxxs.xxx.net\",\"Keywords\":45035996273704960,\"EventType\":\"AUDIT_SUCCESS\",\"SeverityValue\":2,\"Severity\":\"INFO\",\"EventID\":44444,\"SourceName\":\"MSSQLSERVER\",\"Task\":5,\"RecordNumber\":1234343410,\"ProcessID\":0,\"ThreadID\":0,\"Channel\":\"Application\",\"Message\":\"Audit event:lkjfd:sdfkjhf:Askjhdfsdf\",\"Category\":\"None\",\"EventReceivedTime\":\"2024-07-08 04:43:32\",\"SourceModuleName\":\"default-inputs\",\"SourceModuleType\":\"im_msvistalog\"}#015"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.