using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^.*?)(?= ""|(?<=-file)\s[a-z]) ""?([^""\n]+)""?([a-z ]+$)?";
string input = @"some text here -file ""some path here"" potentially some text here
some text here -file some_path_here
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}