re = /(^.*?)(?= "|(?<=-file)\s[a-z]) "?([^"\n]+)"?([a-z ]+$)?/m
str = 'some text here -file "some path here" potentially some text here
some text here -file some_path_here
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end