$re = '/(^.*?)(?= "|(?<=-file)\s[a-z]) "?([^"\n]+)"?([a-z ]+$)?/m';
$str = 'some text here -file "some path here" potentially some text here
some text here -file some_path_here
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);