import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "c:(?:(?<category_id>\\d+\\b)|(\"?)(?<category_name>(?:[^\"\\s]+|[^\"]+))\\2)";
final String string = "python c:192 c:1Stackoverflow c:\"Stack Overflow2\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}