re = /c:(?:(?<category_id>\d+\b)|("?)(?<category_name>(?:[^"\s]+|[^"]+))\2)/
str = 'python c:192 c:1Stackoverflow c:"Stack Overflow2"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end